1. Introduction

To perform computer simulations for the ELEN115 laboratory, MicroSim PSpice A/D was selected as the CAD tool of our choice. It is a simulation program that models the behavior of a circuit containing any mix of analog and digital devices. Used with MicroSim Schematics for design entry, you can think of PSpice A/D as a software-based breadboard of your circuit that you can use to test and refine your design.

2. MicroSim PSpice A/D Functional Overview

Once you prepare a schematic for simulation, MicroSim Schematics generates a circuit file set. The circuit file set, containing the circuit netlist and analysis commands, is read by PSpice for simulation. The results are formulated into graphical traces that can be displayed in a waveform display program called Probe. PSpice can perform:

- DC, AC, and transient analyses, so you can test the response of your circuit to different inputs.
- Parametric, Monte Carlo, and sensitivity/worst-case analyses, so you can see how your circuit’s behavior varies with changing component values.

Fig. 1: The Simulation Process with PSpice
• Digital worst-case timing analysis to help you find timing problems that occur with only certain combinations of slow and fast signal transmissions.

In the Elen115 Lab we will be making use of the AC and transient analysis capabilities of PSpice only. Fig.1 above illustrates the program interaction and basic simulation process.

3. Limitations for the Evaluation Version 8.0

The PSpice Evaluation Version that is available on the lab PCs has the following limitations:

• schematic capture limited to one schematic page (A or A4 size)
• maximum of 50 symbols can be placed on a schematic
• maximum of 10 symbol libraries can be configured
• maximum of 20 symbols in a user-created symbol library
• maximum of 70 parts can be netlisted
• circuit simulation limited to circuits with up to 64 nodes, 10 transistors, two operational amplifiers, or 65 digital primitive devices, and 10 ideal transmission lines with not more than 4 pairwise coupled lines
• device characterization using the Parts utility limited to diodes
• stimulus generation limited to sine waves (analog) and clocks (digital)
• sample library of approximately 30 analog and 130 digital parts

This evaluation Version is included in the “Design Lab” package and can be downloaded from OrCAD website.

4. Overview of Basic Analyses You Can Run with PSpice A/D

4.1 DC sweep & other DC calculations

These DC analyses evaluate circuit performance in response to a direct current source. Table 1 summarizes what PSpice A/D calculates for each DC analysis type.

<table>
<thead>
<tr>
<th>For this DC analysis...</th>
<th>PSpice A/D computes this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>DC sweep</td>
<td>Steady-state voltages, currents, and digital states when sweeping a source, a model parameter, or temperature over a range of values.</td>
</tr>
<tr>
<td>Bias point detail</td>
<td>Bias point data in addition to what is automatically computed in any simulation.</td>
</tr>
<tr>
<td>DC sensitivity</td>
<td>Sensitivity of a net or part voltage as a function of bias point.</td>
</tr>
<tr>
<td>Small-signal DC transfer</td>
<td>Small-signal DC gain, input resistance, and output resistance as a function of bias point.</td>
</tr>
</tbody>
</table>

Table 1: DC Analysis Types
4.2 AC sweep and noise

These AC analyses evaluate circuit performance in response to a small-signal alternating current source. Table 2 summarizes what PSpice A/D calculates for each AC analysis type. Note: To run a noise analysis, you must also run an AC sweep analysis.

<table>
<thead>
<tr>
<th>For this AC analysis...</th>
<th>PSpice A/D computes this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>AC sweep</td>
<td>Small-signal response of the circuit (linearized around the bias point) when sweeping one or more sources over a range of frequencies. Outputs include voltages and currents with magnitude and phase; you can use this information to obtain Bode plots.</td>
</tr>
</tbody>
</table>
| Noise                   | For each frequency specified in the AC analysis:  
  • Propagated noise contributions at an output net from every noise generator in the circuit  
  • RMS sum of the noise contributions at the output  
  • Equivalent input noise |

Table 2: AC Analysis Types

4.3 Transient and Fourier

These time-based analyses evaluate circuit performance in response to time-varying sources. Table 3 summarizes what PSpice A/D calculates for each time-based analysis type. Note: To run a Fourier analysis, you must also run a transient analysis.

<table>
<thead>
<tr>
<th>For this time-based analysis...</th>
<th>PSpice A/D computes this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transient</td>
<td>Voltages, currents, and digital states tracked over time. For digital devices, you can set the propagation delays to minimum, typical, and maximum. If you have enabled digital worst-case timing analysis, then PSpice A/D considers all possible combinations of propagation delays within the minimum and maximum range</td>
</tr>
<tr>
<td>Fourier</td>
<td>DC and Fourier components of the transient analysis results</td>
</tr>
</tbody>
</table>

Table 3: Time-Based Analysis Types
5. Simulation Example

5.1 Example Circuit Creation

This section describes how to use MicroSim Schematics to create the simple diode clipper circuit shown in Figure 2.

---

**Fig.2: Diode Clipper Circuit**

**To Open a new schematic window**

1. Start Schematics. If Schematics is already running, be sure you are in the schematic editor. If you are in a blank schematic window (indicated by “Schematic n” in the title bar at the top of the window), you can begin creating the circuit. If you need to open a new schematic window, from the File menu, select New.

**To Place the voltage sources**

1. From the Draw menu, select Get New Part to display the Part Browser dialog box.
2. In the Part Name text box, type VDC.
3. Click Place & Close or, if you have enough room on your screen, click Place to leave the Part Browser dialog box open.
4. Move the pointer to the correct position on the schematic (see Fig.2) and click to place the first source.
5. Move the cursor and click again to place the second source.
6. Right-click to cancel placement mode.

**To Place the diodes**

1. Go to the Part Browser dialog box.
2. In the Part name text box, type D1N41* to display a list of diodes.
3. Click D1N4148.
4 Click Place (to leave the dialog box open) or Place & Close (to close the dialog box).
5 Press CNTRL+R to rotate the diode outline to the correct orientation.
6 Click to place the first diode (D1), then click to place the second diode (D2).
7 Right-click to cancel placement mode.

To move the text associated with the diodes (or any other object)
1 Click the text once to select it.
2 Drag the text to a new location.

To place the other components
Follow similar steps as described for the diodes to place the components listed below. The symbol names you need to type in the Part name text box of the Part Browser dialog box are shown in parentheses:

- resistors (R)
- capacitor (C)
- ground symbols (EGND)
- bubble symbols (BUBBLE)

If needed, click to redisplay the Part Browser dialog box. When placing components:

- Leave space to connect the components with wires.
- You will change device names and values that don’t match those shown in Fig.2 later in this section. To refresh the schematic display, select Redraw from the View menu or press CNTRL+L.

To connect the components
1 From the Draw menu, select Wire to enter wiring mode. The cursor changes to a pencil.
2 Click the connection point (the very end) of the pin on the bubble at the input of the circuit.
3 Click the nearest connection point of the input resistor R1.
4 Connect the other end of R1 to the output capacitor.
5 Connect the diodes to each other and to the wire between them:
   a Click the connection point of the anode for the lower diode.
   b Move the cursor straight up and click the wire between the diodes. The wire terminates and the junction of the wire segments is made visible.
   c Click again on the junction to continue wiring.
   d Click the end of the upper diode’s cathode pin.
6 Continue connecting components until the circuit is wired as shown in Fig.2.

To assign names (labels) to the nets and bubbles
1 Double-click any segment of the wire that connects R1, R2, R3, the diodes, and the capacitor.
2 In the Label text box, type Mid.
3 Click OK.
4 Double-click each bubble to label it as shown in Fig.2.
To assign names to devices
1 Double-click the reference designator of the VDC symbol, V2.
2 In the Edit Reference Designator dialog box, type Vin in the Package Reference Designator text box.
3 Click OK.
4 Continue naming devices until all circuit devices are named as in Fig.2.

To change the attribute values of devices
1 Double-click the attribute value (0V) of the VDC symbol, V1.
2 In the Set Attribute Value dialog box, type 5V.
3 Click OK.
4 Continue changing the attribute values of the circuit devices until all devices are named as in Fig.2. Your schematic should now have the same symbols, wiring, labels, and attributes as Fig.2.

To save your schematic
1 From the File menu, select Save.
2 Type clipper in the File name text box.
3 Click OK to save the file as clipper.sch

5.2 Bias Point Analysis

To simulate the circuit using PSpice
1 In Schematics, make the clipper.sch window active.
2 From the Analysis menu, select Simulate.

Using the Bias Information Display
You can display bias information on your schematic, including voltages for all nets and currents into all pins. You can also control which nets and pins have voltage and current measurements displayed at any given time.

To display bias voltage information at all nets
1 In Schematics, make the clipper.sch window active.
2 If the Simulation toolbar is not displayed, do the following:
   a From the View menu, select Toolbars.
   b Select ( 3) the Simulation check box, then click Close.
3 If voltages are not displayed, then do the following: On the Simulation toolbar, click the Enable Bias Voltage Display button. DC bias point voltages appear at all nets.

To display bias current through V1, R2, and D1
1 In Schematics, make the clipper.sch window active.
2 On the Simulation toolbar, click the Enable Bias Current Display button.
3 From the Edit menu, select the Select All command.
4 On the Simulation toolbar, click the Show/Hide Currents on Selected Part(s) button.
5 Make sure that no schematic components are selected (by clicking a blank space on the schematic), then shift-click the V1, R2, and D1 symbols.
6 On the Simulation toolbar, click the Show/Hide Currents on Selected Part(s) button. The currents into the pins of V1, R2, and D1 appear.

**To turn the display of bias information off**

1 On the Simulation toolbar, click the Enable Bias Voltage Display button.
2 On the Simulation toolbar, click the Enable Bias Current Display button.

Voltage and current levels no longer display on the schematic. Your settings for the display of voltages and currents are stored.

**Using the Simulation Output File**

The simulation output file acts as an audit trail of the simulation. This file optionally echoes the contents of the circuit file as well as the results of the bias point calculation. If there are any syntax errors in the netlist declarations or simulation commands, or anomalies while performing the calculation, PSpice writes error or warning messages to the output file.

**To view the simulation output file**

1 In Schematics, from the Analysis menu, select Examine Output to display the output file in the MicroSim Text Editor window.
2 When finished, close the MicroSim Text Editor window.

**5.3 Transient Analysis**

This example shows how to run a transient analysis on the clipper circuit. This requires adding a time-domain voltage stimulus as shown in Fig.3.
To add a time-domain voltage stimulus

1. Select the ground symbol beneath the VIN source.
2. From the Edit menu, select Cut.
3. Scroll down or select Out from the View menu.
4. Place a VSIN symbol, then double click it.
5. From the Edit menu, select Paste.
6. Place the ground symbol under the VSIN symbol as shown in Fig.3.
7. From the View menu, select Fit.
8. From the File menu, select Save As, and then type clippert.sch as the name of the schematic file you want to save.
9. Double-click the VSIN symbol.
10. Set values for the VOFF, VAMPL, and FREQ attributes as follows:
    - Offset Voltage = 0
    - Amplitude = 10
    - Frequency = 1kHz

Click “Save Attr” after typing each attribute’s value to accept the changes. When finished, click OK.

To set up and run the transient analysis

1. In Schematics, from the Analysis menu, select Setup.
2. In the Analysis Setup dialog box, click Transient to display the Transient Analysis dialog box.
3. Set up the Transient dialog box as shown in Fig.4

Fig.4: Setup for Transient Analysis
4 Click OK.
5 Click Close to exit the Analysis Setup dialog box.
6 From the File menu, select Save.
7 From the Analysis menu, select Simulate.

Note: PSpice uses its own internal time steps for computation. The internal time step is adjusted according to the requirements of the transient analysis as it proceeds. PSpice saves data to the Probe data file for each internal time step.

To display the input sine wave and clipped wave in Probe
If Probe is set up to automatically open upon successful completion of a simulation (the default setting), the Probe window appears when the simulation is finished.

To plot voltages at nets In and Mid
1 If the Probe window is not yet opened, from the Analysis menu, select Run Probe.
2 From the Trace menu, select Add.
3 Select V(In) and V(Out) by clicking them in the trace list.
4 Click OK to display the traces.

5.4 AC Sweep Analysis
The AC sweep analysis in PSpice is a linear (or small signal) frequency domain analysis that can be used to observe the frequency response of any circuit at its bias point. In this example, you will set up the clipper circuit for AC analysis by adding an AC voltage source for a stimulus signal

To change Vin to include the AC stimulus signal
1 In Schematics, open clippert.sch.
2 Click the DC voltage source, Vin, to select it.
3 From the Edit menu, select Replace.
4 In the Replace Part dialog box, type VAC.
5 Select ( ) the Keep Attribute Values check box.
6 Click OK. The input voltage source changes to an AC voltage source.
7 Double-click the displayed (AC) value of the new Vin.
8 In the Set Attribute Value dialog box, set the value to 1V.

To set up the AC sweep and start simulation
1 From the Analysis menu, select Setup.
2 In the Analysis Setup dialog box, click AC Sweep.
3 Set up the AC Sweep and Noise Analysis dialog box as shown in Fig.5.
Click OK to close the AC Sweep dialog box.
5 Click Close to exit the Analysis Setup dialog box.
6 From the Markers menu, select Mark Advanced.
7 Double-click Vdb.
8 Place one Vdb marker on the output net, and place another on the Mid net.
9 From the File menu, select Save As, and then type clippera.sch as the name of the schematic file you want to save.
10 From the Analysis menu, select Simulate to start the simulation.
11 Because the transient analysis was still enabled, PSpice performs both the transient and AC analyses. The Probe window and the Analysis Type dialog box appear.
12 In the Analysis Type dialog box, click AC.

AC Sweep Analysis Results
Probe displays the dB magnitude (20log10) of the voltage at the marked nets, Out and Mid, as shown in Figure 2-19. VDB(Mid) has a lowpass response due to the diode capacitances to ground. The output capacitance and load resistor act as a highpass filter, so the overall response, illustrated by VDB(out), is a bandpass response. Because AC is a linear analysis and the input voltage was set to 1V, the output voltage is the same as the gain (or attenuation) of the circuit.

To display a Bode plot of the output voltage, including phase
1 In Schematics, from the Markers menu, select Mark Advanced.
2 Place a Vphase marker on the output next to the Vdb marker.
3 Delete the Vdb marker on Mid.
4 Activate the Probe window. The gain and phase plots both appear on the same graph with the same scale.
5 Click the trace name VP(Out) to select it.

Note Depending upon where the Vphase marker was placed, the trace name may be different, such as VP(Cout:2), VP(R4:1), or VP(R4:2).

6 From the Edit menu, select Cut.
7 From the Plot menu, select Add Y Axis.
8 From the Edit menu, select Paste. The Bode plot appears as shown in Fig.6.

Fig.6: Bode Plot of Clipper’s Frequency Response